Author Topic: Technical Updates  (Read 8475 times)

Technical Updates
« on: September 29, 2013, 09:23:30 AM »
This thread is going to be where we'll post all the small tweaks to the site. To start off with:

Sands' announcement about the menu for switching subaccounts being moved is below this thread.
You can access this site via HTTPS (self-signed, without images) by requesting https://tulpanetwork.com.
You can access the FAQ via tulpanetwork.com/faq and the glossary via tulpanetwork.com/glossarytify] tag.
Enabled some HTML usage in posts:
Usable Tags
Code: [Select]
<b>, <u>, <i>, <s>, <em>, <ins>, <del>
<a href="">
<img src="" alt="" />
<br />, <hr />
<pre>, <blockquote>
Enabled some CSS usage in posts:
Usable CSS
Code: [Select]
You can add style and class attributes in [hr], [img], [list], [li], [table], [td] and [tr] tags, e.g., [tag class="class_of_style" style="rules"]text[/tag].


You can add some more attributes to [img] tags:
rotateangle, with angle given in degrees
rotatebgcolor, with colours being 3/6 digit hex codes, r,g,b colours or a name
flip, wth direction being horizontal or vertical

No quotes are given for these, e.g., [img rotateangle=degree rotatebgcolor=color flip=direction]image[/img].


You can add border attributes to [table] tags, specifying the width of the border around the table in pixels, e.g., [table border=number]table content[/table].


You also have [div] and [span] tags to add classes and styles for text.
« Last Edit: December 30, 2013, 06:05:55 PM by waffles »

Re: Technical Updates
« Reply #1 on: December 30, 2013, 06:07:07 PM »
New post because otherwise no-one will read this important information. But check the above post too, especially the HTML/CSS documentation because I think it's pretty neat.

30/12/2013:
Added a "Spam Sucks" button at the bottom of the Headline (default) theme. It links to a form for spambots to fill out that adds them to a spambot IP database, so don't go filling it out yourself.

Re: Technical Updates
« Reply #2 on: January 08, 2014, 03:46:14 PM »
08/01/2014:
Fixed the time which was 24 minutes fast for some reason. I don't know how long it's been like this, nor why, but I'm surprised that no-one reported it.

21/05/2014:
Fixed the time which was 24 minutes slow. I don't know why the forum decided to use the right time recently.

07/07/2014:
The hide tag is now open by default for noscript so if you have Javascript disabled you can see what's in them without looking at the source.
« Last Edit: July 07, 2014, 08:52:08 AM by waffles »

Re: Technical Updates
« Reply #3 on: July 10, 2014, 06:42:29 AM »
10/07/14:
Site was down for a few hours prior to right now because the database broke. I don't know why. I restored to the previous day's backup, and then restored the posts that were made in the meantime. I don't think there were any PMs sent or any polls made since yesterday at 9AM UTC but if there were then they're gone now.

Re: Technical Updates
« Reply #4 on: July 17, 2014, 09:41:34 AM »
17/07/14:

If you're wondering why the index page is going blank sometimes, it's because guest posting breaks the board. I'm trying to fix it but I think I've made it worse. Stay tuned.
Update: I made it better. Patched the forum up a few versions, patched Pretty URLs up a few versions. That seems to have fixed it. I have no idea why it happened but at least it's fixed now.
« Last Edit: July 17, 2014, 10:18:23 AM by waffles »

Re: Technical Updates
« Reply #5 on: September 29, 2014, 04:21:51 PM »
29/09/14:

Turned off the necropost warning since we love necroposts around here.

Re: Technical Updates
« Reply #6 on: December 05, 2014, 11:45:42 AM »
05/12/14: It's clearly that time of the year again because the clock was, what, 29 minutes fast? Fixed it. What the hell.

Re: Technical Updates
« Reply #7 on: April 12, 2015, 03:59:59 PM »
12/04/15: So the server was compromised, apparently. I restored everything (most things - if you see anything amiss, do tell me) from backups, and any posts made after 10AM UTC on Saturday are gone. Sorry.

Re: Technical Updates
« Reply #8 on: December 21, 2015, 12:45:06 PM »
HTTPS re-enabled, kinda. The cert is still self-signed, and you still don't get served images. https://tulpanetwork.com/network.

Re: Technical Updates
« Reply #9 on: February 17, 2016, 09:44:24 AM »
The PMs were ungodly slow before, because the server doesn't have sendmail but was trying to use it apparently. So I changed some things and it seems(???) to be fixed. If sending a PM is ungodly slow, tell me.

Re: Technical Updates
« Reply #10 on: August 03, 2016, 03:41:44 PM »
I moved the forum to a new server. Bye Ramnode, hello DediStation. Things should be pretty much the same, they might be a bit snappier. Tell me if anything breaks.
This also means working SSL for everyone, yay.
« Last Edit: August 03, 2016, 05:40:33 PM by waffles »

Re: Technical Updates
« Reply #11 on: February 20, 2017, 06:07:19 PM »
... I moved the forum back to Ramnode because Dedi was being very unreliable. Things should all work as before; tell me if anything doesn't. There might be a few messages lost since the last successful backup was on the 14th, thanks to the unreliability.

Re: I am an idiot
« Reply #12 on: September 19, 2017, 05:24:38 PM »
I forgot to renew the domain name, so it temporarily lapsed. Everything should be fine now.